Online purchases and updates to personal profiles will be unavailable on the ASCE website Friday, August 30 at 3:00 pm ET through Saturday, August 31 at 11:59 pm ET
You are not logged in. Login

What are the minimum system requirements?

 

Browser and Operation System: You must have an internet connection, a web browser, and Adobe Flash Player 11.2 or greater to attend the Live Webinar using Adobe Connect. Most operating systems including Windows, Macintosh, Linux and Solaris, as well as the most widely used browsers including Internet Explorer, Foxfire, Safari, and Chrome are supported. Test your computer to ensure your computer and network connections are properly configured to provide you with the best possible meeting experience.

Pop-up Blockers: All Pop-up blockers must be disabled.

Audio: Use a telephone or the Voice-over-IP (VoIP) option (listen through your computer’s speakers).

For more information, visit Adobe Help or call MeetingOne help desk at 1-888-523-8445.

To view handouts for the Live Webinar, transcripts, or certificates, you must have Adobe Reader installed on your computer.