Online purchases and updates to personal profiles will be unavailable on the ASCE website Friday, August 30 at 3:00 pm ET through Saturday, August 31 at 11:59 pm ET
You are not logged in. Login

On-Demand Webinar and On-Demand Seminar System Requirements (Brightcove Player)

End users should have one of the following browser and Flash versions installed to play On-Demand Webinars and On-Demand Seminars using the Brightcove player:

  Windows PC

Mac

Browser

  • Chrome
  • Firefox 3.0.1 or higher
  • Internet Explorer 6 SP1
  • Internet Explorer 7
  • Internet Explorer 8
  • Internet Explorer 9
  • Internet Explorer 10[3]
  • Safari 3.2.2 or higher
  • Safari 4 or higher
 
  • Chrome
  • Firefox 3.0.1 or higher
  • Safari 3.2.1 or higher
  • Safari 4 or higher
 

Flash

  • Flash Player 11.1 r102+
  • Flash Player 11.0 r1+
  • Flash Player 10.3 rxxx
  • Flash Player 10.2 rxxx
 
  • Flash Player 11.1 r102+
  • Flash Player 11.0 r1+
  • Flash Player 10.3 rxxx
  • Flash Player 10.2 rxxx
 
Firewall

Please ask your IT Administrator to allow
the following URLs in their Firewall policy.

  • *.brightcove.com
  • bcove.me
  • *.o.brightcove.com
  • brightcove04.o.brightcove.com
  • hls.ak.o.brightcove.com
  •  uds.ak.o.brightcove.com
  • brightcove.vo.llnwd.net
  • *.llnwd.net
  • *.edgefcs.net
  • *.edgesuite.net
  • *.akamaihd.net
  • *.scanscout.com
  • *.analytics.edgekey.net
 

PC or MAC Users
*Make sure Javascript is enabled

[3] - Video Cloud only supports the default browser on the device (IE10) in the Windows 8 Modern UI.

Note that only the client versions of Windows are officially supported, and an error is known to occur when a player loads in Internet Explorer 9 on Windows Servers 2008. You may be able to resolve this issue by installing the optional Desktop Experience component on Windows Server 2008.

Mobile requirements
End users using Android devices are not required to have Flash Player installed. For detailed information, see Supported Devices for HTML5 Players